Service outage

Incident Report for Napta

Postmortem

We would like to share an overview of a service interruption that occurred on May 6th, 2025, affecting access to the Napta application. Below is a timeline of events, a simplified explanation of the cause related to a database update, and the actions we are taking.

Timeline of Events

  • 1:46 PM CET: Users began experiencing issues accessing the Napta application.
  • 1:54 PM CET: Our monitoring systems triggered "too many 5xx" alarms, indicating a high volume of errors.
  • 2:00 PM CET: Issue was identified and a fix was launched.
  • 2:06 PM CET: Access to the application was fully restored.

Root Cause

The interruption occurred during a planned update to our platform that included changes to the structure of our application's database (a database schema migration). An automated process that applies these database changes ran in an unexpected order relative to the application's code update. This temporary mismatch meant the application's software was looking for data in a database structure that wasn't yet fully in place, preventing it from operating correctly.

Action Plan

To prevent similar incidents related to database updates, we are reinforcing the synchronization between database updates and application code updates in our deployment processes to ensure they occur in the correct order, and we are reviewing the thresholds and sensitivity of our alarms to provide earlier warnings of service disruptions.

Closing Remarks

We sincerely apologize for the disruption this service interruption caused. We understand the importance of a reliable platform and are committed to continuously improving our systems and processes to minimize the risk of future incidents.

If you have any further questions, please don’t hesitate to contact our support team.

Posted May 12, 2025 - 21:22 UTC

Resolved

This incident has been resolved.
Posted May 06, 2025 - 12:10 UTC

Monitoring

The issue is mitigated and we're now monitoring it.
Posted May 06, 2025 - 12:05 UTC

Identified

We've identified the cause of the problem and are working on it
Posted May 06, 2025 - 11:57 UTC

Investigating

We are currently experiencing service outage on app.napta.io, our team is looking into this.
Posted May 06, 2025 - 11:55 UTC
This incident affected: Application.