User Session Disruptions

Incident Report for Napta

Postmortem

We would like to share an overview of a service interruption that occurred on December 19, 2025, affecting access to the Napta application. Users experienced intermittent disconnections and “401 Unauthorized” errors. Below is a timeline of events, an explanation of the cause related to our authentication provider, and the actions we are taking to prevent recurrence.

Timeline of Events

  • 3:50 PM CET: Users began experiencing intermittent disconnections and errors (identified retrospectively from logs).
  • 5:22 PM CET: The issue was detected by our team following user reports of frequent “Unauthorized” errors.
  • 5:36 PM CET: Our engineering team initiated a restart of the affected backend services to force a configuration refresh.
  • 5:55 PM CET: Error rates dropped to zero and access to the application was fully restored.

Root Cause

The interruption was caused by temporary instability with our third-party authentication provider. During this period, the third party service was temporarily unreachable or unstable.
Consequently, a specific subset of our backend services failed to retrieve the necessary configuration upon startup. Without this configuration, these affected services could not verify the digital signatures of user tokens. This resulted in valid users being treated as unauthenticated only when routed to these specific instances, leading to immediate disconnections and 401 errors upon navigation or idle return.

Action Plan

To prevent similar incidents, we have deployed specific monitoring to detect authentication provider outages immediately. Additionally, we are updating our application code to include automatic retry mechanisms, ensuring the system can recover autonomously if the authentication provider becomes temporarily unreachable.

Closing Remarks

We sincerely apologize for the disruption this service interruption caused. We understand the importance of a reliable platform and are committed to continuously improving our systems to minimize the risk of future incidents.
If you have any further questions, please don’t hesitate to contact our support team.

Posted Dec 23, 2025 - 16:22 UTC

Resolved

The issue causing application instability and frequent disconnections has been fully resolved. The platform is now operating normally, and the incident is considered closed. Thank you for your understanding and patience throughout this process.
Posted Dec 19, 2025 - 17:14 UTC

Monitoring

The root cause of the issue causing application instability and frequent disconnections has been identified. A fix has been deployed, and the service is now stable. Our team will continue to closely monitor the situation to ensure full resolution. Thank you for your patience.
Posted Dec 19, 2025 - 16:55 UTC

Investigating

We are currently experiencing intermittent instability causing users to be frequently disconnected from the application. Our engineering teams are actively investigating the issue to restore full stability as soon as possible. We will provide updates as more information becomes available.
Posted Dec 19, 2025 - 16:39 UTC
This incident affected: Application.